© GALeon, 2005
 
:: Навигатор :.

::: Автоматизация бизнеса ::.
  • Бухгалтерский учет
  • Складской учет
  • Управленческий учет
  • Финансовый анализ
  • CRM - решения (Управление клиентами)
 
:: Мы делаем :.
  • быстро
  • качественно
  • не дорого
Не отказывайте себе в удовольствии выбрать все ТРИ пункта!
 
:: Советы начинающим :.
ПО "1С:ПРЕДПРИЯТИЕ 7.7":
 
:: Наши проекты :.
О платформе 1С

::Универсальный фильтр по справочникам:.

:: Galeon... ...или наши работы

Как заставить работать универсальный фильтр?

  • 1.Скачать и разархивировать Filtr.zip .
  • 2.Обработку Фильтр.ert сохранить в каталог ExtForms рабочей базы.
  • 3.В форму списка справочника нужно вставить кнопку кнФильтр с именем "Фильтр" и привесить к ней обработчик нажатия.
  • Процедура УстФильтр())
        Конт=Вид();
        //ОткрытьФормуМодально("Обработка.Фильтр",Конт);
        ОткрытьФормуМодально("Отчет",Конт,КаталогИБ()+
     	"ExtForms\Фильтр.ert");
        Если Конт=Вид() Тогда
    	Возврат;
        Иначе
          Если Конт.РазмерСписка()=0 Тогда
    	Форма.кнФильтр.Заголовок("Фильтр");
    	ИерархическийСписок(1,1);
    	ИспользоватьСписокЭлементов();
          Иначе
    	Форма.кнФильтр.Заголовок("Фильтр включен");
    	ИерархическийСписок(0,0);
    	ИспользоватьСписокЭлементов(Конт);
          КонецЕсли;
        КонецЕсли;
    КонецПроцедуры
    
  • 4.Все. Запускайте 1С Предприятие, заходите в справочник и формируйте фильтр.
  • 5.Вопросы, предложения и пожелания автору на galeonXXI@narod.ru.


:: Реклама :.
 
:: Новости :.
  • Как сделать ножны ножу?
 
: Что мы можем? Все! : Наши проекты : Контакты :

webmaster galeonXXI&yandex.ru Яндекс.Метрика


Hosted by uCoz